How to upgrade VMware VDS using vSphere Web Client 5.1

Blog & Tutorials — By on Tuesday, September 18th, 2012

This how-to will go through steps on upgrading virtual Distributed Switch in VMware vSphere 5.1. I wanted to test and enable some of the new features in the new Vmware vSphere 5.1, particularly those related to VDS, such as LACP and Health check so decided to perform an upgrade on vDS in my home virtualization lab.

There are multiple tools available to take care of this, you can perform vDS upgrade from vSphere client or the new Web Client 5.1 (few options just in web client ). Lets get started and login to the vSphere Web Client...

Note: You can upgrade from 4.0, 4.1 and 5.0 to 5.1 but you cannot downgrade so make sure you are ready for the upgrade as there is no going back.

You can perform the upgrade without any downtime.

  1. Once you are logged in, click on the network icon as shown in the screenshot below
    VMware virtual distributed switchAs you can see the VDS is version 5.0, new features are highlighted as "not supported"
  2. After selecting the distributed switch which you want to upgrade, click on "Actions" link to bring down sub-menu, as shown below
    distributed switch drop down menuFrom here you can click on "Upgrade Distributed Switch".
  3. You can also RIGHT CLICK on the VDS and click "Upgrade Distributed Switch," as shown below in the screenshot
  4. Regardless of which method you use, you will be presented with "Upgrade Distributed Switch" wizard which will check the hosts for compatibility with the VDS 5.1 version, as shown below
    Distributed Switch Upgrade wizard

The wizard guides you through to...

  • Configure upgrade
    Specific distributed switch version for upgrade
  • Version 5.1.0
    This version is compatible with VMware ESXi version 5.1 and later. The following new features are available: Management Network Rollback and Recovery, Health Check, Enhanced Port Mirroring, and LACP.
  • Check compatibility, warning:
    Some VMware ESX Server members of the distributed switch are not compatible with the new distributed switch version. Upgrade or remove the incompatible hosts to proceed.
    To support version 5.1 on all hosts, the hosts must be upgraded to ESXi 5.1 as well.
  • ready to complete, warning
    Once upgraded the distributed switch cannot be downgraded to a previous distributed switch version. You will not be able to add older VMware ESX Server members that are not compatible with the new distributed switch.

 

I hope this how to tutorial was helpful. Please post in our forums or contact via email if you have any questions or suggestions.

 

Related Topic Tags


Comments are closed.